Ruby / How to solve a MySQL gem install error (Failed to build gem native extension)

The following error occurred while installing the mysql gem into a gemset:

Most likely it happens due to absence of some command or lib or anything else (in my current setup there is simply no mysqlclient installed, for instance).

There is a way to fix it. The next command did the trick for me:

Some additional insights on this problem: https://rapd.wordpress.com/2007/05/17/battle-against-ror-gem-install-mysql/

No comments:

Post a Comment